Announcement

Collapse
No announcement yet.

Never ending turbo saga! (Boost issues).

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Never ending turbo saga! (Boost issues).

    How do,

    Had a long term issue with my turbo where it boosts fine but seems to halt and then boost again (almost like it just stops for a split second).

    I've replaced:

    Diverter valve
    Fitted GFB
    Spark plugs
    Coil packs
    MAF sensors
    Lambda sensor

    Aftermarket parts are a Forge induction kit and a Cobra sports exhaust. Everything else is stock.

    I really have no idea where to go from here, even my local garage is stumped!

  • #2
    Any fault codes?

    I had something similar, where my Turbo disappeared on my THP on a few journeys. Cant remember how I resolved the issues

    Have you disconnected the Turbo, and looked in the tubes as sometimes oil gets in there
    sigpic
    Jog on Noddy

    Comment


    • #3
      Thanks Chris. I have had a look around most of the connecting pipework and used some MAF cleaner to get grime out.

      The more I read up on it though I'm convinced it's the wastegate actuator that needs adjusting but it's an absolute nightmare to get to on the THP (if at all without removing the turbo or front bumper).

      Comment


      • #4
        Originally posted by theelectricyoot View Post
        Thanks Chris.
        The more I read up on it though I'm convinced it's the wastegate actuator that needs adjusting but it's an absolute nightmare to get to on the THP (if at all without removing the turbo or front bumper).
        I don't think removing the front bumper is that bad- I had the Forge front bumper dismantling guide, and I will be giving it a go soon to upgrade the intercooler

        So you could give it a go, or maybe take it to the local mechanic?

        sigpic
        Jog on Noddy

        Comment

        Working...
        X