Announcement

Collapse
No announcement yet.

Reversing Sensors......No message no beep, nowt ????AAAGGHHH HELP !

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reversing Sensors......No message no beep, nowt ????AAAGGHHH HELP !

    Hello, this is my first post.

    I have recently acquired a nice DStyle + 1.6 VTi. Now I am quite well versed in cars but this has stumped me and i refuse to pay 100 just to get it checked out. When i engage reverse...nothing happens, nada, zilch. My reversing light works and my monochrame A screen stated my parking assist is active in the menu but no error message. I do not here the engaged beep nor any other beep and any picture on my screen. I have checked the wires at the back of the OEM stereo, I have checked all fuses in the glove comaprtment, I have check the wiring around the reverse bulb. I have checked to see if my sensors click which they do not and finally this really confused me, thinking it was the module, I pulled the black plug out and a warning message appeared stating my parking assist was faulty with the service indicator lit up. Plug it back in again and everything is fine....or what i started with at least. So my question is this:
    Is it the Module?
    Is it the Sensors?
    Or is it an Enigma?

    Some help on this would be greatly appreciated. Ive scoured these boards and the internet and the only problems i see is everyone gets an error msg if its faulty, and i could deal with that hehe...

    Please, Please Help....

    Thanks in Advance

  • #2
    Maybe the gate switch in the gear lever is broken? That'd explain it not engaging at all. You checked the bulb wiring but did you check the reverse bulb itself? Second port of call would be body control unit possibly, happened to mine.
    ///DStyle+ VTi 120 in white/black/red ///
    Join the Facebook Group!
    Join the Discord Server!

    Comment


    • #3
      Thanks for the comment. I have checked the bulb and it come on when i put car in reverse. The wiring is all fine and the body control unit, i take it that the black box right hand side behind the packing? When is disconnected the black plug my display then said i had a fault. Put and OBDII on it also and no faults found. I am just baffled. Would the gate switch still activate the reverse bulb?

      Comment


      • #4
        I must spell check more often hehe....

        Comment


        • #5
          Yeah the gate should control the bulb and sensors, so if the bulb is lighting it can't be that. I can only think of taking a multimeter and tracking the connection to find where it's failing.

          Also not sure where the BCU is, had garage do it for me, they put in a second hand one from a scrappy.
          ///DStyle+ VTi 120 in white/black/red ///
          Join the Facebook Group!
          Join the Discord Server!

          Comment


          • #6
            I'm not too sure it's the BCU as when i pull the main black plug out it then says the fail message on the screen, plug it back in and nothing again. But hey, I may try the swap see what happens, it may work hehe

            Comment


            • #7
              My next question would be, if i did switch the BCU over would i have to use the Lexia tool?

              Comment


              • #8
                Not sure, I think BCU is ok but it's the BSI which is the one coded to the car which needs reprogramming.
                ///DStyle+ VTi 120 in white/black/red ///
                Join the Facebook Group!
                Join the Discord Server!

                Comment


                • #9
                  UPDATE..........Still need help though.......Swapped over all 4 sensors and now i get a message of 'PARKING ASSIST ERROR' so at least i know the sensors were shot, although i need to get the ones that are shaped as a 'Z' so they will fit. My question then, is this the fault of the rear BCU? If so can i just swap out or will it need to be programmed? Your help would be grateful.

                  Comment

                  Working...
                  X