Announcement

Collapse
No announcement yet.

P2191

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Just looking at some old data logs from a few different cars I can see the fuel pressure response is almost instant in most cases, definately under 1 second for pump to achieve 120bar from 48bar on snap full throttle.
    Your reading of 130bar tells me your tuner has increased the fuel pressure. Even though combustion benefits from a higher pressure I don't like to do this on a THP, its not necessary. This puts more stress on the already weak chocolate fuel pumps.
    So maybe you have a lazy pump, did you post before that you had fitted a pump which was not new, used already?
    White on red THP
    Miltek exhaust with HKS highflow cat, Forge intercooler, hard pipe kit, induction kit, oil catch tank, , VAG BOV, Stage 3 SPT remap 217 BHP

    Comment


    • #17
      This is on stock tune, the 130 is only 128 bar.
      But yes, this is a used one from a car that had only a few thousand miles on it. Only 1 second ? Very lazy pump i have. Only takes 1 second to build up to 100bar but takes 4 seconds for the last 28 bar.

      Also, fuel pressure is ok when cruizing at 90km/h? Then when does it still say it's lean at that speed ?

      Comment


      • #18
        120bar is max requested fuel pressure on a stock tune so it's strange you reach 128bar.
        White on red THP
        Miltek exhaust with HKS highflow cat, Forge intercooler, hard pipe kit, induction kit, oil catch tank, , VAG BOV, Stage 3 SPT remap 217 BHP

        Comment


        • #19
          Humm, that's wierd then. I don't know what has happend to the ecu, but it's also from another car. A brittish one where the maried bsi was right hand drive configured.

          I can't yet read it out. Still waiting for my kessv2 to immo off my second ecu, i should be able to read the map using odb2 with the kess ? Maybe thats why the citroen ecu update failed?

          Just a little report from a small test drive last night. Using torque at a 100ms sampling rate. You'll see the 130 bar.

          https://drive.google.com/file/d/0B4a...w?usp=drivesdk

          Comment


          • #20
            I've got some more time off when i get back from the uk. I'll try everything i know and see how that goes. If it's still not ok, i'll buy a kess and immo off the second ecu i've got with original citroen software. As i can not be sure the one i'm using now is. It will justify me buying a kessv2. Or should i get a fgtech? Jury still not out on that one...

            Comment


            • #21
              It's likely then your ecu is already tuned....
              I wouldn't trust any of the tools you mentioned if they are cloned tools...
              White on red THP
              Miltek exhaust with HKS highflow cat, Forge intercooler, hard pipe kit, induction kit, oil catch tank, , VAG BOV, Stage 3 SPT remap 217 BHP

              Comment


              • #22
                Originally posted by Jamie@SPTuning View Post
                It's likely then your ecu is already tuned....
                I wouldn't trust any of the tools you mentioned if they are cloned tools...
                Ok, thanks. Probably not a very good tune then. I've driven a racing before and didn't feel that much quicker. I'll give that kess one a try, they do seem to work. If i send over the ecu file jamie, could you confirm for me ?

                Comment


                • #23
                  Update: replaced the front o2 sensor and checked full exhaust system. A few bolts from the exhaust manifold were lose and the gasket between the turbo and catalyst was blow. Replaced the gasket.
                  Had another look at all the sensors and they are all ok. No vacuum leak and the hpfp is good. Timing was checked again it's spot on. A few minutes from perfect and min is 88degrees.

                  Result: same as before. High LTFT that causes a p2191.

                  Next step: tear out hear and cry...
                  Naaa, got a kess coming in and will have a try with a diffrent ecu. Anyone here that has a full flash and eeprom dump of a THP 150 that is good? Any chance of anyone having a immo off dump ?

                  Can only be the ecu, as all the rest checks out. If i'm not forgetting something sensor wise.

                  Comment


                  • #24
                    What should the timing advance be at 2000 rpm at 90 kph on cruise control ? It's at 30 degrees but that does seem a bit high ?

                    Also put diagbox on a tablet and monitored all the values whilest driving. Compared the readed values to the expected/requested values. The fuel pressure, manifold pressure, etc. All are perfect and spot on.



                    Last edited by V3nn3tj3; 20-10-2017, 17:49.

                    Comment


                    • #25
                      Originally posted by V3nn3tj3
                      Update: replaced the front o2 sensor and checked full exhaust system. A few bolts from the exhaust manifold were lose and the gasket between the turbo and catalyst was blow. Replaced the gasket.
                      Had another look at all the sensors and they are all ok. No vacuum leak and the hpfp is good. Timing was checked again it's spot on. A few minutes from perfect and min is 88degrees.

                      Result: same as before. High LTFT that causes a p2191.

                      Next step: tear out hear and cry...
                      Naaa, got a kess coming in and will have a try with a diffrent ecu. Anyone here that has a full flash and eeprom dump of a THP 150 that is good? Any chance of anyone having a immo off dump ?

                      Can only be the ecu, as all the rest checks out. If i'm not forgetting something sensor wise.
                      I have 99% of all the THP flash files....
                      What year is the car?
                      White on red THP
                      Miltek exhaust with HKS highflow cat, Forge intercooler, hard pipe kit, induction kit, oil catch tank, , VAG BOV, Stage 3 SPT remap 217 BHP

                      Comment


                      • #26
                        Car is from januari 2010

                        Comment


                        • #27
                          Hi,

                          I'm thinking of selling or burning down the car at this stage...
                          Still have the same problem. Took a week off work and started working on the car. This is what i did.

                          1. Walnut blast the valves. Will post pictures later as they are on the tablet. Fun diy project...
                          2. Changed the ecu software to a good flash confirmed by Jamie (thanks !)
                          3. All new seals everywhere.
                          4. Compression test
                          5. Replaced all the sensors. All of them. 2 map sensors, cam sensor, cranksensor and even the knock sensor.
                          6. Timing was checked and found within spec
                          7. Checked wiring of all sensors to ecu (thank god for sedre).

                          Result: after a 10km test drive the LTFT goes to 10%, when doing the 50km drive to work i hit the 25% mark and go into limp mode.

                          I know all my sensors are good. All values are perfect. HPFP is good, values are anyway. No vacuum leaks. Measured air and fuel pressures are what the ecu is expecting, etc.
                          How the hell is this car not running fine? On idle the injection times are .9ms and thats what it should be. But why does it run lean when driving ? Only thing i can think of are clogged injectors. Is this a thing or a common problem ?
                          But wouldn't clogged injectors keep the engine running lean at idle also ? Thing is that the engines STFT is constantly between 10 and 15% after the LTFT are resetted except at idle or at full load. When i do get a LTFT of, for example, 20% the STFT is - 20% on idle but above 0 when driving.
                          It is also hitting the max LTFT alot faster after the walnut blast, more air = leaner engine?

                          Only thing i haven't replaced yet are the injectors and post cat o2 sensor. Any ideas ?

                          Thanks


                          Comment


                          • #28
                            Maybe your PCV? Try capping it off on the manifold, reset adaptions and re test.
                            White on red THP
                            Miltek exhaust with HKS highflow cat, Forge intercooler, hard pipe kit, induction kit, oil catch tank, , VAG BOV, Stage 3 SPT remap 217 BHP

                            Comment


                            • #29
                              Originally posted by Jamie@SPTuning View Post
                              Maybe your PCV? Try capping it off on the manifold, reset adaptions and re test.
                              Pvc is completly deleted and capped of using the correct plug from citroen/peugeot.


                              Comment


                              • #30
                                Also, i've been thinking which can be dangerous. Clogged injectors will result in higher pressures measured by the sensor ? Ifso that might explain why i get 130bar for a very short time when it should only be 120 at the max as i see in the map of the car... The 130 drops to 120 almost instantly but thats the ecu compensating i guess.

                                Or is this a wrong conclusion ? Anyone tried cleaning or rebuilding the valves ? They are expensive.

                                Comment

                                Working...
                                X